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Jetro CockpIT™ Version 3.0
     
   

JKB00341 Failed to Trigger Application 2

Symptoms
When launching an application using the virtual desktop the user receives the following error:

“Failed to trigger application process, please contact your system administrator”

         

Causes

  1. The path to the executable is invalid (JKB00340).
  2. Active directory (or local) group policy “Run Logon Scripts Synchronously” set to “not configured” or “disabled”.

This article gives the resolutions for cause #2. Refer to the referenced JKB articles for the other cause.

When CockpIT connects the user to a Terminal Server in order to run an application, the server logs the user in and runs a series of scripts. One script will map drive letters to the appropriate UNC paths of network shared directories. Sometimes, the server attempts to launch an application that is located on a mapped drive letter, while the script has not yet mapped the directory. When this happens, the server is not able to trigger the application and it displays the above message. The solution is to set the “Run logon script synchronously” setting to “Enabled.”

Resolution

  1. Logon as an administrator with rights to change Domain Group Policies for the server or the domain.
  2. Select Start, Run, and enter “mmc”.
  3. Select Console, then Add/Remove Snap-in…, click on Add
  4. If your CockpIT server is using Active Directory, then select Active Directory Users and Computers and Add. Otherwise, proceed to step #5.
  5. 4.1. Select Close and OK
    4.2. Expand Active Directory Users
    4.3. Select the domain, right click, and select Properties
    4.4. Select Default Domain Policy and Edit


    4.5. Go to step #6.

  6. If your CockpIT server is using local group policies rather than Active Directory, then select Group Policy, Add, then select “Local Computer”, Close, OK.
  7.  

    5.1. Select Local Computer Policy

  8. Select User Configuration, Administrative Templates, System, Logon/Logoff,

6.1. Right click on Run logon script synchronously, and select Properties.
6.2. Select Enabled and OK.


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